If you are not registered or logged in, you may still use these forums but with limited features. Show recent topics
  [Search] Search   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [FAQ]  FAQ 
[Register] Register / 
[Login] Login 
Messages posted by: BadBoo
Forum Index » Profile for BadBoo » Messages posted by BadBoo
Author Message
Ok. Well, everything pointed to it being a sql connection error because of an invalid SQL password. I deleted the account in cpanle SQl admin (not phpMySql) and recreated it with a known password, put in the hash (not plain text) and it works again. Sure would like to know how the has is created, so I could change my sql password at will.

Thx for the help Carbonize

Thanks, I have already updated all the tables manually using MyPhpAdmin, created the pics folder, changed the case from upper to lowercase in last-visit, and changed from null etc etc. This is the second one I have done, so I am not concerned about the admin page (as I stated figuring that someone would mistake this for a admin loop error)

Rather, i think i need to change the password for the sql user account accessing the database. I don't see how to change the sql user password in myPhpAdmin. Do you know how to do that?

One thing I have thought of is to delete the user, and then recreate the user with a known password.

Another point, on the other web site with a working Advanced Guestbook 2.31 (that I upgraded by hand), if I change the password to plain text, I get this exact same error, when i go back to the obfuscate hash, it works again. I think the problem is, determining how the hash work, and getting the correct hash put in place. Any ideas?
When trying to connect to:
I get this error:

Warning: mysql_connect(): Access denied for user: 'bdmeyer_agbook1@localhost' (Using password: YES) in /home/bdmeyer/public_html/guestbook/lib/mysql.class.php on line 30
Connection Error

MySQL Error : Connection Error
Error Number: 1045 Access denied for user: 'bdmeyer_agbook1@localhost' (Using password: YES)
Date : Sun, October 17, 2004 11:43:15
IP :
Browser : Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Referer :
PHP Version : 4.3.8
OS : Linux
Server : Apache/1.3.31 (Unix) mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 FrontPage/ mod_ssl/2.8.19 OpenSSL/0.9.7a PHP-CGI/0.1b
Server Name : www.motuning.com

I believe it is (but not certain) the password that goes here in config.inc.php:

$GB_DB["dbName"] = "changd_agbook1";
$GB_DB["host"] = "localhost";
$GB_DB["user"] = "changd_agbook1";
$GB_DB["pass"] = "SumPasswd";

On a working guestbook I just upgraded, it has what looks like an obfuscated password like:
$GB_DB["pass"] = "s_2wery46dhde2"; (made up)
In a message on this forum someone described to enter 'the password for your sql database.' So I entered it in plain text also. Niether works.
Two things are possible:
1.) I need that password to be obfuscated hash of the correct password. (if so, how do I get the hash?)
2.) I don't have the correct MySQL password entered.

Please note: I am not referring to the test 123 username / passwor combo. I know exactly how to fix that, and this isn't in the admin part. This is just getting to the guestbook period.

I guess there is a third option:
line 30 referenced in the error message is the checksessionID thing discussed in this forumn.
$AUTH = $gb_auth->checkSessionID();

I have deleted relevant cookies and all temp internet files, to no avail.

Any help will be greatly appreciated.
This is from a 2.2 to 2.31 upgrade.

Bruce Meyer
I did an upgrade from 2.2. to 2.31.
I had the problem of logging in, and then being asked to login again whenever I clicked on anything from the admin menu.

This s what I did to solve the problem after deleting and uploading the new 2.31 files (with appropriate changed to config.inc.php)

The fix for me was Kerry's post. Since he isn't real clear in his explanation, I am writing the fix he describes:

Go to MyPHPAdmin, and pull up the table:
by clicking on it on the leftmost column.

Now place a check mark in the box to the left of LAST_VISIT
Now click on the icon to the right (7 columns to the right) that looks like a piece of paper with a pencil over it. The mouseover will say 'change'

change FIELD from LAST_VISIT to last_visit
(just change it to lower case)

the second column should be:

the third column should be:

the fourth column (attributes) should be empty, (blank, nothing in it.)

the 5th coulmn (NULL) should be 'not null'

the 6th column should be:

The 8th and final column should be blank (empty, nothing in it)

Now over to the left, and down under the FIELD column is a 'save' button. Click on Save.
This fixed two of my guestbook that I had upgraded from 2.2. to 2.31, and run the upgrade.sql script on.

Hope it helps, and thanks for being smart Kerry!
Forum Index » Profile for BadBoo » Messages posted by BadBoo
Go to:   
Based on the open source JForum